Skocz do zawartości

Problem z wyświetlaniem zdjęć - czarne paski, czarne tło, losowe przeglądarki

Polecane posty

Witam

Proszę o podpowiedź jak rozwiązać problemy z wyświetlaniem zdjęć w allegro, polegające na wyświetlaniu zdjęć które na spodzie mają czarny pasek lub całe są czarne.

Problem występuje praktycznie w każdej wystawionej przez sello ofercie, co ciekawe w niektórych przeglądarkach zdjęcia wyświetlają się poprawnie, ale na to nie ma reguły. ( tzn. na jednym komputerze na chromie banglają, a na drugim nie etc )

Przesyłam opis wykonanych testów i ustawień sello, żeby wykluczyć zbędne podpowiedzi:

  • wyświetlanie ofert sprawdziłem również w zakładkach incognito - problem tam też występuje
  • zdjęcia nie są uszkodzone
  • zdjęcia w formatach JPG
  • wszystkie oferty zostały wystawione z sello po pobraniu pełnych danych dla aukcji ( brak błędów )
  • wszystkie dane do ofert pobrały się elegancko tzn. z poziomu sello w galeriach wszystkie zdjęcia wyświetlają się bezbłędnie 
  • opcja " zmniejszaj zdjęcia wysłane do serwisu..."  jest wyłączona
  • oferty wystawiane są z komputera który łączy się przez wi-fi z bazą danych znajdującą się na serwerze

Zauważyłem, że problem można rozwiązać poprzez usunięcie zdjęć z galerii i wczytanie ich od nowa do sello. Mam bardzo dużo ofert i nie chciałbym tracić czasu na zabawę w odświeżanie ofert.

Załączam screen z podglądem błędu.

Proszę o sugestie.

skrin.png

skrin.png.c05b60f84404d407353280961a13e4f8.png

Edytowane przez Książe Goro
Link to postu

Też to zauważyłem i się zdziwiłem. Czarny pasek na dole świadczy o uciętym zdjęciu i Allegro uzupełnia je czarnym paskiem (taka moja uwaga). Więc albo Sello podczas wysyłania aukcji, wysyła zdjęcia z błędami, albo serwer Allegro powoduje błędy.

Edytowane przez Mariusz Kownacki
Link to postu

Ten problem już wystąpił w Allegro pół roku temu - nie miał związku z Sello, bo zniknął tak samo jak się pojawił.

Dnia 10.08.2019 o 14:14, Książe Goro napisał:

co ciekawe w niektórych przeglądarkach zdjęcia wyświetlają się poprawnie, ale na to nie ma reguły.

Wystarczy nawet odświeżyć stronę poprzez ctrl+F5 i paski raz są, raz nie ma.

Badamy temat, dam znać jak coś uda się ustalić.

Link to postu
1 godzinę temu, Bartosz Rosa napisał:

Ten problem już wystąpił w Allegro pół roku temu - nie miał związku z Sello, bo zniknął tak samo jak się pojawił.

Wystarczy nawet odświeżyć stronę poprzez ctrl+F5 i paski raz są, raz nie ma.

Badamy temat, dam znać jak coś uda się ustalić. 

Nie jestem pewien na ile można powiedzieć, że to nie ma związku z Sello - mamy ten sam problem i tutaj pewne uwagi:

- problem pojawił się po aktualizacji do 1.31

- (jeżeli to ma jakiekolwiek znaczenie) również korzystamy z Sello na zasadzie klientów podłączonych do centralnego serwera

- tworzenie i wystawienie aukcji bezpośrednio z Allegro nie daje takich błędów

- błędy w wyświetlaniu zdjęć są widoczne tylko w opisie (w galerii jest ok)

- nie ma ich na sello, tylko w obrębie allegro

- obecne tylko na aukcjach wystawionych po aktualizacji do 1.31, utworzonych poprzez powielenie trwających - faktycznie błędy NIE WYSTĘPUJĄ dla zdjęć, które się wstawiło do aukcji od nowa

- porównałem też zdjęcia z paskami vs pierwowzory - pasek nie zostaje "dołożony" - wysokość obrazka się nie zmienia, tylko czarny pasek "zasłania" pewną część zdjęcia od dołu

Edytowane przez Maciej Kuc
Link to postu

Generalnie crtl + F5 nic nie zmienia. Błędy nadal występują. Dodatkowo chciałem zauważyć, że w sello nie można podmienić zdjęć znajdujących się w ofertach trwających i wysłać do allegro na "podmiankę" ponieważ wtedy pojawia się błąd "metoda została wyłączona".

W miarę możliwości proszę o dalsze wskazówki.

Link to postu

A co powiedzieć na taki przypadek, przed chwilą na swoich prywatnych aukcjach (gdzie również są paski a aukcje były wystawiane przez mobilną aplikację kilka miesięcy temu) również są widoczne czarne paski. Po wyświetleniu samego zdjęcia w przeglądarce pojawił się również pasek ale tym razem biały. Po odświeżeniu strony z aukcją pasek zniknął z opisu.

Zdjęcia wysyłane do Allegro są skalowane w serwisie na różne warianty, i tak poniżej wariant 720p (można to odczytać po ścieżce url zdjęcia: Pasek jest

https://a.allegroimg.com/s720/xxxxxxxx

image.png.774b0e822371ffe4296e372bfb95dcf1.png

Poniżej wariant 480p tego samego zdjęcia, paska nie ma

https://a.allegroimg.com/s480/xxxxxxx

image.png.b946c453c7e321825b813b7bed654b88.png

Poniżej oryginalne zdjęcie dostępne w Allegro: paska nie ma

https://a.allegroimg.com/original/xxxxxxx

image.png.9c7cc31665f58be8161f56dbd0106804.png

Ewidentnie pasek pojawia się przy skalowaniu zdjęć.

 

image.png.774b0e822371ffe4296e372bfb95dcf1.png

image.png.b946c453c7e321825b813b7bed654b88.png

image.png.9c7cc31665f58be8161f56dbd0106804.png

Link to postu
13 minut temu, Książe Goro napisał:

Dodatkowo chciałem zauważyć, że w sello nie można podmienić zdjęć znajdujących się w ofertach trwających i wysłać do allegro na "podmiankę" ponieważ wtedy pojawia się błąd "metoda została wyłączona".

Funkcja zmian zbiorczych będzie dostępna w wersji 1.32 już niebawem.

Link to postu
1 godzinę temu, Bartosz Rosa napisał:

A co powiedzieć na taki przypadek, przed chwilą na swoich prywatnych aukcjach (gdzie również są paski a aukcje były wystawiane przez mobilną aplikację kilka miesięcy temu) również są widoczne czarne paski. Po wyświetleniu samego zdjęcia w przeglądarce pojawił się również pasek ale tym razem biały. Po odświeżeniu strony z aukcją pasek zniknął z opisu.

Zdjęcia wysyłane do Allegro są skalowane w serwisie na różne warianty, i tak poniżej wariant 720p (można to odczytać po ścieżce url zdjęcia: Pasek jest

https://a.allegroimg.com/s720/xxxxxxxx

image.png.774b0e822371ffe4296e372bfb95dcf1.png

Poniżej wariant 480p tego samego zdjęcia, paska nie ma

https://a.allegroimg.com/s480/xxxxxxx

image.png.b946c453c7e321825b813b7bed654b88.png

Poniżej oryginalne zdjęcie dostępne w Allegro: paska nie ma

https://a.allegroimg.com/original/xxxxxxx

image.png.9c7cc31665f58be8161f56dbd0106804.png

Ewidentnie pasek pojawia się przy skalowaniu zdjęć.

 

 

Sprawdziłem jedno ze zdjęć z "zepsutej" aukcji i faktycznie:

- oryginał (800x600) - ok

- 720p (720x540) - pasek 7-8px

- 480p (512x384) - ok

Skoro to samo wywaliło na wystawieniu z mobilnej apki, to najbardziej prawdopodobnym winowajcą jest nowe API Allegro, tylko dlaczego to się nie dzieje na zdjęciach dodanych od nowa przy tworzeniu aukcji... ?

Link to postu

To już pytanie bardziej do Allegro. Problem z paskami zgłoszony został wczoraj.

Link to postu
  • 2 tygodnie później...

Wróciłem z urlopu i problem znikł, dziękuję za interwencję.

Link to postu
  • 2 tygodnie później...

Niestety, problem nadal występuje:

image.png.3942a26dcd2af98b573b53c5ef155170.png

Ponowne wrzucanie zdjęć dla kilku tysięcy aukcji jest niewykonalne, co można z tym zrobić?

 

image.png.3942a26dcd2af98b573b53c5ef155170.png

image.png.3942a26dcd2af98b573b53c5ef155170.png

Link to postu

Badaliśmy sprawę wczoraj i ponownie doszliśmy do wniosku, że to algorytm skalowania w Allegro dodaje paski białe lub czarne. Pytanie jeszcze dlaczego je dodaje, czy jest to kwestia zdjęcia, jego rozmiarów, proporcji, sposobu wysyłania zdjęć do API? Tak czy inaczej nasze badania i wnioski przesłaliśmy też do analizy do Allegro, zobaczymy czy uda się namierzyć problem.

Co do samych pasków, to czasami ctrl+F5 w przeglądarce powoduje, że czarny pasek zamienia się w biały, więc wysyłanie ich od nowa nie ma sensu (przynajmniej dopóki nie ustalimy źródła problemu).

Link to postu

Mam ten sam problem, oferta od wielu lat nie było z nią problemów, nagle mam paski czarne.

Link to postu

Teraz, oprócz pasków, pojawiają się całe czarne zdjęcia :)

image.png.4bcef6a94efde09c1a9a9d3be9328c88.png

image.png.4bcef6a94efde09c1a9a9d3be9328c88.png

Link to postu

Czy wejście w podgląd tych zdjęć i ewentualne odświeżenie przeglądarki przez ctrl+F5 coś zmienia?

Nie mamy jeszcze informacji od Allegro co może być źródłem.

Link to postu

Niestety, nie zmienia. Tutaj przykładowy link do zdjęcia:

https://a.allegroimg.com/s720/110089/4f2341e84f53bcc5e293f9c651be

  • Dziękuję 1
Link to postu

Nie nie zmienia, te zdjęcia są chyba uszkodzone w serwisie Allegro. Uszkodzenie sprawia wrażenie losowego, tzn raz to samo zdjęcie jest uwalone, innym razem w innej aukcji to samo zdjęcie jest OK. Jakby jakieś błędy transmicji czy co ...

Link to postu
  • 2 tygodnie później...

Czy coś wiadomo już w tej kwestii? Problem nadal występuje.

Link to postu

U mnie również problem występuje. Czy jest jakaś zbiorcza możliwość naprawienia tego? Ręczna zmiana dla kilku tysięcy ofert na kilku kontach nie wchodzi w grę.

Link to postu

Przyślijcie do nas kilka zdjęć, które po wgraniu do Sello i wysłaniu mają te czarne paski (sello@insert.com.pl)

Link to postu
Dnia 30.09.2019 o 11:01, Bartosz Rosa napisał:

Przyślijcie do nas kilka zdjęć, które po wgraniu do Sello i wysłaniu mają te czarne paski (sello@insert.com.pl)

Ja mam już całą miniaturkę czarną na listingu Allegro.

W skrócie wygląda tak:

image.png.3a43cc0fecfb0df70d41bd811a9d7f25.png

 

image.png.3a43cc0fecfb0df70d41bd811a9d7f25.png

Edytowane przez HotKey .
Link to postu

Otrzymałem informację, że problem został namierzony i w najbliższym czasie poprawka będzie wdrożona.

  • Dziękuję 2
Link to postu

Czy te zdjęcia, które zostały oznaczone czarnym paskiem będą poprawione?

Link to postu

Tego nie wiem, ale raczej jest to kwestia skalowania zdjęć więc (przynajmniej teoretycznie) po stronie serwerów można usunąć "skeszowame" błędne zdjęcia aby wygenerowały się nowe.

Link to postu
  • 3 tygodnie później...

Znalazłem też oferty z których zniknęły wszystkie zdjęcia. Jest ich 5 sztuk ofert.

Link to postu

Dołącz do dyskusji

Możesz dodać zawartość już teraz a zarejestrować się później. Jeśli posiadasz już konto, zaloguj się aby dodać zawartość za jego pomocą.

Gość
Odpowiedz...

×   Wklejono zawartość z formatowaniem.   Usuń formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Odnośnik został automatycznie osadzony.   Przywróć wyświetlanie jako odnośnik

×   Przywrócono poprzednią zawartość.   Wyczyść edytor

×   Nie możesz bezpośrednio wkleić grafiki. Dodaj lub załącz grafiki z adresu URL.

×
×
  • Dodaj nową pozycję...