Skocz do zawartości

Długie tworzenie dokumentów końcowych na komputerze klienckim (Subiekt GT 1.67 HF1)

Polecane posty

Może to jakieś "światełko w tunelu":

 

Zamknąłem Subiekta GT. Potem na komputerze wyłączyłem wszystkie osłony w programie antywirusowym i następnie otworzyłem Subiekt GT. Program na wyłączonych osłonach uruchomił się bardzo szybko. Tak ekspresowo jak przed aktualizacją ...

Potem przez Sello kliknąłem Towary => Synchronizuj z Subiektem GT i również poszło bardzo szybko. Tak ekspresowo jak przed aktualizacją ...

Nie miałem czasu dalej sprawdzać ale już widzę że u mnie tędy droga 🤗.

  • Dziękuję 1
Link to postu

Hmm, ale przecież nie chodzi o to, żeby wyłączać wszystkie zapory w programie antywirusowym, to ma chronić, nie wiem, ale insert powinien to rozwiązać aktualizacją, przecież było dobrze, dopiero po aktualizacji subiekta do 1.67 HF1 zaczęły dziać się takie cuda, a klienci są wściekli, że tyle czasu muszą czekać na paragon / fakturę.

Zgłaszałam problem w insercie telefonicznie, ale oczywiście mnie zbyli, że to tylko ja mam problem. Więc proszę pomęczcie ich, musi być nas więcej, żeby cokolwiek zaczęli działać! 

Link to postu
5 godzin temu, Damian Uruszczak napisał:

Pytanie jest jakie antywirusy powodują problem. 

To nie antywirusy powodują problem !! bo one były (u każdego jakiś, na tym samym komputerze z Subiektem) przez cały czas, od lat. Przez ten cały czas i od lat aktualizowały się antywirusy, aktualizował się Subiekt i wszystko chodziło = współpracowało. To 1 fakt.

Do ostatniej aktualizacji Subiekta, która "psuje" program w opisany wyżej sposób i u wielu użytkowników w ten sam sposób. To 2 fakt.

W tej chwili na każdym komputerze (u każdego) funkcjonuje w zestawieniu z antywirusem wiele innych programów ale tylko Subiekt GT po aktualizacji wykazuje objawy awarii. To 3 fakt.

To co napisałem wczoraj o antywirusie to tylko wskazówka, spostrzeżenie, które wskazuje, że Subiekt po zmianach wniesionych aktualizacją przy włączonej ochronie objawia problem a przy wyłączonej, tylko w opisanych operacjach, które zdążyłem zrobić nie objawia.

Ale to Subiekt GT ma problem z funkcjonowaniem a nie antywirus, ochrona Windows ani inne programu użytkowane na komputerze, które każdy z nas ma do pracy w firmie. Problem w problemie jest taki, że Subiekt GT to jeden z tych najważniejszych programów.

Edytowane przez Rafał Żuk
Uzupełnienie
  • Lubię to 1
Link to postu

Wychodzi na to jakby zapora blokowała Subiekta do dostępu do bazy danych SQL. Trochę dziwne, że tak się dzieje na komputerze lokalnym. Panie Rafał Żuk, jakiego masz antiwirusa lub zaporę? Czy po dodaniu wyjątku w zaporze i odblokowaniu portów, nadal występuje ten objaw?

  • Lubię to 1
Link to postu

Cześć,

U mnie problem właśnie powrócił.

Subiekt przed aktualizacją, po aktualizacji bez zmian.

"Struktura podmiotu prawidłowa" w tym momencie przywieszenie Subiekta.

Po uruchomieniu Sello długo podłącza do systemu sprzedaży.

Problem na komputerze na którym jest serwer SQL oraz Subiekt i Sello (na końcówkach również).

 

Link to postu

Dzięki za informacje i wskazówki, przekazałem je dalej do teamu GT.

 

Jeszcze pytanie, czy próbowaliście usunąć Subiekta i zainstalować go ponownie? Kiedyś był pewien problem na niektórych systemach z nainstalowaniem jednej wersji na drugą i takie działanie rozwiązywało problem. Może i tutaj będzie podobnie, jeśli to kwestia niepoprawnej instalacji.

 

No i druga sprawa, czy wyłączenie tych programów antywirusowych i zapór sieciowych na chwilę i restart Subiekta zmienia coś w jego działaniu?

Link to postu
10 godzin temu, Mariusz Kownacki napisał:

Panie Rafał Żuk, jakiego masz antiwirusa lub zaporę?

Na ochronę komputera składa się wszystko to co oferuje standardowo Windows 10 plus Avast Premium Security.

 

10 godzin temu, Mariusz Kownacki napisał:

Czy po dodaniu wyjątku w zaporze i odblokowaniu portów, nadal występuje ten objaw?

Nigdy tego nie robiłem bo problemu nie było. Pisząc "nigdy" mam na myśli okres minimum 6 lat, w którym ta konfiguracja pracowała bez najmniejszych zakłóceń (w tym czasie programy na bieżąco były aktualizowane), do dnia zaktualizowania Subiekt GT do wersji 1.67 HF2.

Czy istnieje wątek albo poradnik opisujący operację, którą Pan doradza?

Link to postu
3 godziny temu, Bartosz Rosa napisał:

 

Jeszcze pytanie, czy próbowaliście usunąć Subiekta i zainstalować go ponownie? Kiedyś był pewien problem na niektórych systemach z nainstalowaniem jednej wersji na drugą i takie działanie rozwiązywało problem. Może i tutaj będzie podobnie, jeśli to kwestia niepoprawnej instalacji.

 

No i druga sprawa, czy wyłączenie tych programów antywirusowych i zapór sieciowych na chwilę i restart Subiekta zmienia coś w jego działaniu?

Panie Bartku u mnie jedyna zmiana od wczoraj (kiedy systemy działały normalnie) to podłączenie laptopa do innej sieci. Raz był to internet przez radio od lokalnego dostawcy, a dziś internet z Plus-a. Taka konfiguracja jest od dawna.

Subiekta odinstaluję w późniejszych godzinach i dam znać (ale problem pojawił się przed instalacją nowszej wersji Subiekta).

 

Reinstalacja Subiekta nic nie dała.

Edytowane przez Remigiusz Pawlak
Link to postu
2 godziny temu, Bartosz Rosa napisał:

Czyli to nie jest ten problem opisywany w wątku.

Dla mnie jest, objawy są takie jak opisywane wyżej, Subiekt muli przy uruchamianiu, z Sello dokumenty wystawiają się makabrycznie długo, może to nie jest wina wersji Subiekta a np może jakiejś aktualizacji Windowsa, a może szaleje konfiguracja sieci (nie wiem czy może samoczynnie szaleć, nie znam się). A jeśli to nie ten sam problem to proszę o pomoc w jego rozwiązaniu. Dziś 140 faktur wystawiało się od godziny 6 rano do 13, tak nie da się pracować.

  • Lubię to 1
Link to postu
W dniu 12.07.2021 o 09:23, Rafał Żuk napisał:

Na ochronę komputera składa się wszystko to co oferuje standardowo Windows 10 plus Avast Premium Security.

 

Nigdy tego nie robiłem bo problemu nie było. Pisząc "nigdy" mam na myśli okres minimum 6 lat, w którym ta konfiguracja pracowała bez najmniejszych zakłóceń (w tym czasie programy na bieżąco były aktualizowane), do dnia zaktualizowania Subiekt GT do wersji 1.67 HF2.

Czy istnieje wątek albo poradnik opisujący operację, którą Pan doradza?

Niestety nie ma takiego wątku ani poradnika. Ja bym spróbował dodać do wyjątku w zaporze Subiekt.exe oraz plik bazy danych Subiekta, chociaż to i tak byłaby to metoda prób i błędów.

Link to postu

Chyba nie tędy droga. U mnie nie ma żadnych rozwiązań firm zewnętrznych. Korzystam wyłącznie z Windows Defender oraz systemowej zapory w której do wyjątków dodane są porty 1433 i 1434. Wszystko działało od lat w tej konfiguracji aż do momentu aktualizacji Subiekta do 1.67. W sklepie u kolegi gdzie zainstalowana jest starsza wersja Subiekta wszystko działa bez zarzutu.

Na wiadomość z logami które wysłałem do analizy nadal brak odpowiedzi. Zapytałem w kolejnej wiadomości czy udało się coś wyciągnąć z przesłanych plików - brak odpowiedzi. To nie pierwsza sytuacja kiedy na wiadomości w Insert nikt nie odpowiada.

Praca jest utrudniona nie tylko na Subiekcie ale również na Sello. Dodawanie dokumentów - 2 minuty. Anulowanie zamówień z usunięciem ZK w Subiekcie - 2 minuty. DRAMAT! Przy samej sprzedaży internetowej jeszcze można kombinować. ale współczuje gdy ktoś ma rozbujaną sprzedaż lokalną gdzie klienci przychodzą jeden za drugim.

Edytowane przez Krzysztof Fruga
Link to postu
W dniu 13.07.2021 o 09:28, Mariusz Kownacki napisał:

Niestety nie ma takiego wątku ani poradnika. Ja bym spróbował dodać do wyjątku w zaporze Subiekt.exe oraz plik bazy danych Subiekta, chociaż to i tak byłaby to metoda prób i błędów.

Przeczytałem trochę materiałów znalezionych w sieci o tym temacie.
Metoda prób i błędów w zakresie operacji / czynności które w razie czego można cofnąć jest jak najbardziej przydatna i użyteczna.

 

W nawiązaniu do powyższego, opisanej zależności od "programów osłaniających" postanowiłem kolejno, od podstawowych potestować zmiany ustawień "programów osłaniających" (antywirus Avast Premium Security). Początek to ustawienie Profil Zapory Ogniowej, do chwili zmiany miałem [ Sieć publiczna ], przełączyłem na [ Sieć prywatna ], sprawdziłem i wszystko ruszyło. Subiekt GT łączy się bez zwłoki, Sello również współpracuje z Subiektem bez zwłoki.
Także dużo się nie natestowałem, metoda prób i błędów dała efekt przy pierwszej czynności. Zrobiłem to we wtorek 13.07.2021 wieczorem i do dziś pracuję. Co najważniejsze nie ma zwłoki i czekania przy wcześniej opisanych czynnościach. Mimo to Subiekt GT teraz objawia "dolegliwości" w innej formie, tak od czasu do czasu (około 3-4 razy dziennie):

 

20210715_212340.jpg.7d156a78175f61ebaeff0cdaba0b283a.jpg

 

Ikona na pomarańczowym tle, po "kliknięciu":

 

20210716_083341.jpg.cff59b0627057c7aa8b713f4bcfa367a.jpg

 

ekran "powitalny - początkowy" zamiast roboczego z uruchomionymi zakładkami [Sprzedaż detaliczna], [Zamówienia od klientów], [Towary].

 

To jednak dużo mniejszy problem niż poprzednio bo da się pracować.

  • Dziękuję 1
Link to postu
W dniu 17.07.2021 o 12:14, Rafał Żuk napisał:

Przeczytałem trochę materiałów znalezionych w sieci o tym temacie.
Metoda prób i błędów w zakresie operacji / czynności które w razie czego można cofnąć jest jak najbardziej przydatna i użyteczna.

 

W nawiązaniu do powyższego, opisanej zależności od "programów osłaniających" postanowiłem kolejno, od podstawowych potestować zmiany ustawień "programów osłaniających" (antywirus Avast Premium Security). Początek to ustawienie Profil Zapory Ogniowej, do chwili zmiany miałem [ Sieć publiczna ], przełączyłem na [ Sieć prywatna ], sprawdziłem i wszystko ruszyło. Subiekt GT łączy się bez zwłoki, Sello również współpracuje z Subiektem bez zwłoki.
Także dużo się nie natestowałem, metoda prób i błędów dała efekt przy pierwszej czynności. Zrobiłem to we wtorek 13.07.2021 wieczorem i do dziś pracuję. Co najważniejsze nie ma zwłoki i czekania przy wcześniej opisanych czynnościach. Mimo to Subiekt GT teraz objawia "dolegliwości" w innej formie, tak od czasu do czasu (około 3-4 razy dziennie):

 

20210715_212340.jpg.7d156a78175f61ebaeff0cdaba0b283a.jpg

 

Ikona na pomarańczowym tle, po "kliknięciu":

 

20210716_083341.jpg.cff59b0627057c7aa8b713f4bcfa367a.jpg

 

ekran "powitalny - początkowy" zamiast roboczego z uruchomionymi zakładkami [Sprzedaż detaliczna], [Zamówienia od klientów], [Towary].

 

To jednak dużo mniejszy problem niż poprzednio bo da się pracować.

W jakimś wątku (niestety nie pamiętam gdzie) ktoś pisał, że do prawidłowej pracy Sello i Subiekta (jak i pewnie innych programów) sieć musi być ustawiona na sieć prywatną/firmową, zamiast publiczną. Przy publicznej sieci zapora systemu lub antywirusa blokuje programy również te lokalne, natomiast przy prywatnej/firmowej blokowane są zewnętrze połączenia. Na komputerach klienckich w sieci LAN, również musi być ustawiona sieć prywatna/firmowa.

  • Dziękuję 1
Link to postu

w moim przypadku pomógł  zabieg proponowany przez @Mariusz Kownacki , czyli zmiana sieci na prywatną.

Problem powstał po aktualizacji WIN10. 
Wie ktoś, czy Insert podejmuje jakieś działania w celu usunięcia problemu, czy tak już zostanie? 

 

Link to postu

Czy u innych osób, które mają ten problem, zabieg ze zmianą typu sieci pomógł?

 

9 godzin temu, Paweł Nitendel napisał:

Wie ktoś, czy Insert podejmuje jakieś działania w celu usunięcia problemu, czy tak już zostanie? 

Informację od Was przekazuję do teamu GT, ale to już od nich zależy czy coś będzie zrobione. Czy ustawienie tej sieci na prywatną jest jakimś problemem?

Link to postu

Dołącz do dyskusji

Możesz dodać zawartość już teraz a zarejestrować się później. Jeśli posiadasz już konto, zaloguj się aby dodać zawartość za jego pomocą.

Gość
Odpowiedz...

×   Wklejono zawartość z formatowaniem.   Usuń formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Odnośnik został automatycznie osadzony.   Przywróć wyświetlanie jako odnośnik

×   Przywrócono poprzednią zawartość.   Wyczyść edytor

×   Nie możesz bezpośrednio wkleić grafiki. Dodaj lub załącz grafiki z adresu URL.

×
×
  • Dodaj nową pozycję...