Skocz do zawartości

Brak połączenia Subiekt Nexo 37.0.0 z Sello 1.39.0

Polecane posty

Zaktualizowałem sebiekt'a do najnowszej wersji i po uruchomieniu sello otrzymałem takie info:

 

Synchronizacja z systemem sprzedaży: System sprzedaży nie uruchomił się prawidłowo. Nie można wykonać tego zadania bez działającego systemu sprzedaży.

 

Zrobiłem test połączenia i otrzymałem takie coś:

 

sello.jpg

Link to postu

Sello zaktualizowane, komunikacja z subiektem przywrócona, zamówienia ZK tworzą się automatycznie bez problemu ale gdy chcę utworzyć dokument końcowy - wskaźnik myszy kręci się 8s a następnie sello się wywala.

Dokumenty końcowe dziś zrobiłem z poziomu subiekta i sello zassało sobie numery dokumentów końcowych.

Może jednak da się coś zrobić aby dokumenty końcowe wystawiać z poziomu sello?

 

  • Smutny 1
Link to postu
2 godziny temu, Marek Wardawa napisał:

Sello zaktualizowane, komunikacja z subiektem przywrócona, zamówienia ZK tworzą się automatycznie bez problemu ale gdy chcę utworzyć dokument końcowy - wskaźnik myszy kręci się 8s a następnie sello się wywala.

Dokumenty końcowe dziś zrobiłem z poziomu subiekta i sello zassało sobie numery dokumentów końcowych.

Może jednak da się coś zrobić aby dokumenty końcowe wystawiać z poziomu sello?

 

Wszystko działa poprawnie u nas. Masz Sello 1.39.1 i nexo 37?

Link to postu
11 godzin temu, Marek Wardawa napisał:

Sello zaktualizowane, komunikacja z subiektem przywrócona, zamówienia ZK tworzą się automatycznie bez problemu ale gdy chcę utworzyć dokument końcowy - wskaźnik myszy kręci się 8s a następnie sello się wywala.

Dokumenty końcowe dziś zrobiłem z poziomu subiekta i sello zassało sobie numery dokumentów końcowych.

Może jednak da się coś zrobić aby dokumenty końcowe wystawiać z poziomu sello?

 

Witam

mnie też wywala sello podczas tworzenia dokumentów końcowych

  • Smutny 1
Link to postu
12 godzin temu, Marek Wardawa napisał:

wskaźnik myszy kręci się 8s a następnie sello się wywala

 

48 minut temu, Krzysztof Buczyński napisał:

mnie też wywala sello podczas tworzenia dokumentów końcowych

Czy dotyczy to dowolnych dokumentów (PA, PAi, FS, FSd)? Proszę sprawdzić czy dzieje się tak zarówno przy użyciu funkcji Dokument końcowy jak i Dokumenty końcowe, oraz Utwórz z dolnej zakładki DOKUMENTY.

Problem dotyczy Sello w połączeniu z Subiektem nexo 37?

 

Proszę również o przesłanie zrzutu pamięci (plik DMP).

 

Spoiler

W przypadku nieoczekiwanego zamknięcia programu, tworzony jest zrzut pamięci, który w większości przypadków umożliwia odtworzenie u nas miejsca w którym wystąpił problem i jego poprawienie. Zrzut pamięci w postaci pliku o nazwie Sello_rok_miesiąc_dzień_godzina_minuta_sekunda.dmp zapisywany jest w folderze:

C:\Users\<Nazwa_konta>\AppData\Roaming\InsERT Sello\

Plik, lub pliki wskazujące na odpowiednią datę wystąpienia problemu należy przesłać do nas na adres sello@insert.com.pl wraz z krótkim opisem kiedy ten błąd występuje, numerem wersji Sello, ewentualnie linkiem do forum gdzie opisany jest problem.

 

Link to postu
12 minut temu, Bartosz Rosa napisał:

 

Czy dotyczy to dowolnych dokumentów (PA, PAi, FS, FSd)? Proszę sprawdzić czy dzieje się tak zarówno przy użyciu funkcji Dokument końcowy jak i Dokumenty końcowe, oraz Utwórz z dolnej zakładki DOKUMENTY.

Problem dotyczy Sello w połączeniu z Subiektem nexo 37?

 

Proszę również o przesłanie zrzutu pamięci (plik DMP).

 

  Ukryj zawartość

W przypadku nieoczekiwanego zamknięcia programu, tworzony jest zrzut pamięci, który w większości przypadków umożliwia odtworzenie u nas miejsca w którym wystąpił problem i jego poprawienie. Zrzut pamięci w postaci pliku o nazwie Sello_rok_miesiąc_dzień_godzina_minuta_sekunda.dmp zapisywany jest w folderze:

C:\Users\<Nazwa_konta>\AppData\Roaming\InsERT Sello\

Plik, lub pliki wskazujące na odpowiednią datę wystąpienia problemu należy przesłać do nas na adres sello@insert.com.pl wraz z krótkim opisem kiedy ten błąd występuje, numerem wersji Sello, ewentualnie linkiem do forum gdzie opisany jest problem.

 

Tak występuje to przy tworzeniu dokumentu końcowego typu fs , pai, pa  - to przetestowałem

 

natomiast działa w schemacie:

najpierw utwórz dokument początkowy np zk z rezerwacją, potem przechodzimy do subiekta do zamówień bieżących  - tworzymy dokument końcowy 

potem pobieramy dokument do sello i pojawia się jego nr w sello i potem  tworzymy paczkę 

 

  • Dziękuję 1
Link to postu

W moim przypadku dotyczy to PAi oraz FS.

Opisywana sytuacja występuje w trakcie tworzenia dokumentów w dolnej zakładce jak również funkcji "Dokument końcowy".

W przypadku "Dokumentów końcowych" otrzymałem "nie można zablokować podanego zasobu" - podsyłam log

Ostatni plik DMP mam z 24 wrześnie (z przed aktualizacji) - brak nowszych

 

 

Edytowane przez Bartosz Rosa
Dumpy usunięte ze względów bezpieczeńswa
Link to postu
23 minuty temu, Bartosz Rosa napisał:

Ok, rozwiązaniem będzie podmiana pliku Sello.exe.config, znajdującego się w C:\Program Files (x86)\InsERT\Sello\ na plik załączony w tym wątku.

 

Jeśli w tym pliku były dokonywane jakieś modyfikacje (np zmiana parametrów wysyłania paczek do InPostu) i jego nadpisanie nie wchodzi w grę to można ten plik również wyedytować edytorem tekstu i dopisać poniższą konfigurację w węźle <configuration> (na samym końcu, przed tagiem zamykającym </configuration> )

 


	<runtime>
		<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
			<dependentAssembly>
				<assemblyIdentity name="Newtonsoft.Json" publicKeyToken="30ad4fe6b2a6aeed" culture="neutral"/>
				<bindingRedirect oldVersion="6.0.0.0-12.0.0.0" newVersion="13.0.0.0"/>
			</dependentAssembly>
		</assemblyBinding>
	</runtime>

 

 

Sello.exe.config 2 kB · 2 pobrania

ok, działa

dzięki

  • Lubię to 1
Link to postu
9 godzin temu, Bartosz Rosa napisał:

Ok, rozwiązaniem będzie podmiana pliku Sello.exe.config, znajdującego się w C:\Program Files (x86)\InsERT\Sello\ na plik załączony w tym wątku.

 

Jeśli w tym pliku były dokonywane jakieś modyfikacje (np zmiana parametrów wysyłania paczek do InPostu) i jego nadpisanie nie wchodzi w grę to można ten plik również wyedytować edytorem tekstu i dopisać poniższą konfigurację w węźle <configuration> (na samym końcu, przed tagiem zamykającym </configuration> )

 


	<runtime>
		<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
			<dependentAssembly>
				<assemblyIdentity name="Newtonsoft.Json" publicKeyToken="30ad4fe6b2a6aeed" culture="neutral"/>
				<bindingRedirect oldVersion="6.0.0.0-12.0.0.0" newVersion="13.0.0.0"/>
			</dependentAssembly>
		</assemblyBinding>
	</runtime>

 

 

Sello.exe.config 2 kB · 5 pobrań

Dokumenty końcowe wystawiają się poprawnie, DZIĘKI ZA POMOC

  • Lubię to 1
Link to postu

A u mnie niespodzianka... Po nadpisaniu jaki i po ręcznym wklejeniu kodu w plik (w Notepad++) występują błędy:

 

(zarówno przy GT jak i przy NEXO (poniższy błąd jako część komunikatu z Raportu)

Nie można załadować pliku lub zestawu 'Newtonsoft.Json, Version=13.0.0.0, Culture=neutral, PublicKeyToken=30ad4fe6b2a6aeed' lub jednej z jego zależności. Zlokalizowana definicja manifestu zestawu nie odpowiada odwołaniu do zestawu. (Wyjątek od HRESULT: 0x80131040) (0x80131040)

 

Wgrałem pierwotny plik. Sello uruchamiane jako admin.

 

Link to postu
W dniu 30.09.2021 o 12:39, Bartosz Rosa napisał:

Ok, rozwiązaniem będzie podmiana pliku Sello.exe.config, znajdującego się w C:\Program Files (x86)\InsERT\Sello\ na plik załączony w tym wątku.

 

Jeśli w tym pliku były dokonywane jakieś modyfikacje (np zmiana parametrów wysyłania paczek do InPostu) i jego nadpisanie nie wchodzi w grę to można ten plik również wyedytować edytorem tekstu i dopisać poniższą konfigurację w węźle <configuration> (na samym końcu, przed tagiem zamykającym </configuration> )

 


	<runtime>
		<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
			<dependentAssembly>
				<assemblyIdentity name="Newtonsoft.Json" publicKeyToken="30ad4fe6b2a6aeed" culture="neutral"/>
				<bindingRedirect oldVersion="6.0.0.0-12.0.0.0" newVersion="13.0.0.0"/>
			</dependentAssembly>
		</assemblyBinding>
	</runtime>

 

 

Sello.exe.config 2 kB · 8 pobrań

Czy jest to równiez rozwiązanie dla Subiekta GT?

Link to postu
W dniu 30.09.2021 o 12:39, Bartosz Rosa napisał:

Ok, rozwiązaniem będzie podmiana pliku Sello.exe.config, znajdującego się w C:\Program Files (x86)\InsERT\Sello\ na plik załączony w tym wątku.

 

Jeśli w tym pliku były dokonywane jakieś modyfikacje (np zmiana parametrów wysyłania paczek do InPostu) i jego nadpisanie nie wchodzi w grę to można ten plik również wyedytować edytorem tekstu i dopisać poniższą konfigurację w węźle <configuration> (na samym końcu, przed tagiem zamykającym </configuration> )

 


	<runtime>
		<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
			<dependentAssembly>
				<assemblyIdentity name="Newtonsoft.Json" publicKeyToken="30ad4fe6b2a6aeed" culture="neutral"/>
				<bindingRedirect oldVersion="6.0.0.0-12.0.0.0" newVersion="13.0.0.0"/>
			</dependentAssembly>
		</assemblyBinding>
	</runtime>

 

 

Sello.exe.config 2 kB · 9 pobrań

Pomogło, aczkolwiek, zupełnie losowo w dalszym ciągu program potrafi zamknąć się bez ostrzeżenia. Podgląd dokumentu jest WŁĄCZONY.

 

 

Link to postu
W dniu 1.10.2021 o 08:58, MARCIN e-kupowanie.pl Sello1.39.1 napisał:

A u mnie niespodzianka... Po nadpisaniu jaki i po ręcznym wklejeniu kodu w plik (w Notepad++) występują błędy:

Które masz wersje Subiektów?

 

W dniu 1.10.2021 o 13:00, Paweł Nitendel napisał:

Czy jest to równiez rozwiązanie dla Subiekta GT?

Poprawka 1.39.1 nie ma związku z Subiektem GT. Czy z działaniem z nim jest jakiś problem?

W dniu 1.10.2021 o 13:22, R2 D2 napisał:

zupełnie losowo w dalszym ciągu program potrafi zamknąć się bez ostrzeżenia. Podgląd dokumentu jest WŁĄCZONY.

W dalszym ciągu, tzn. że wcześniej na wersji nexo starszej niż 37 też się zamykało w losowych momentach, czy dopiero teraz po instalacji 37 i Sello 1.39.1 zaczęło?

 

 

Link to postu
2 minuty temu, Bartosz Rosa napisał:

Które masz wersje Subiektów?

obraz.png.55fd2bacbdf8c009dbcad78b6cc31bea.png obraz.png.9a6a2cdad109de2c4b0cd2098ef9d0e3.png

3 minuty temu, Bartosz Rosa napisał:

Czy z działaniem z nim jest jakiś problem?

Tak, był. Tak jak podawałem powyżej - błędy w obu Subiektach (czyli w RAPORCIE Sello) takie same (o ile pamiętam na dzisiaj, bo wycofałem ten dopisek i czekam na 1.40)

Link to postu
2 godziny temu, Bartosz Rosa napisał:

Które masz wersje Subiektów?

 

Poprawka 1.39.1 nie ma związku z Subiektem GT. Czy z działaniem z nim jest jakiś problem?

W dalszym ciągu, tzn. że wcześniej na wersji nexo starszej niż 37 też się zamykało w losowych momentach, czy dopiero teraz po instalacji 37 i Sello 1.39.1 zaczęło?

 

 

Nie jestem w stanie powiedzieć - wcześniej praca na SGT. To jest absolutnie nowa baza Nexo i Sello. Wszystko zostało postawione od zera i od razu problemy...

 

Link to postu

Dołącz do dyskusji

Możesz dodać zawartość już teraz a zarejestrować się później. Jeśli posiadasz już konto, zaloguj się aby dodać zawartość za jego pomocą.

Gość
Odpowiedz...

×   Wklejono zawartość z formatowaniem.   Usuń formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Odnośnik został automatycznie osadzony.   Przywróć wyświetlanie jako odnośnik

×   Przywrócono poprzednią zawartość.   Wyczyść edytor

×   Nie możesz bezpośrednio wkleić grafiki. Dodaj lub załącz grafiki z adresu URL.

×
×
  • Dodaj nową pozycję...