Skocz do zawartości
Forum użytkowników
Katarzyna Drabik

Koniec wsparcia dla TLS 1.0 i 1.1

Polecane posty

Napisano (edytowany)

Witam serdecznie

W dniu dzisiejszym od rana naglę w raportach pojawiły się błędy o problemach z wysyłką wiadomości do klientów. Wysłanie maila testowego z tej samej skrzynki lecz poza sello i z włączonym szyfrowaniem bez problemu. Po przesłaniu błędu do mojego admina od hostingu polecił mi wyłączenie w sello szyfrowania na poczcie wychodzącej dla testu i to pomogło. Zapytałem go zatem co dalej z tym bo powinno być szyfrowanie włączone. Odpowiedź:

"Koniec wsparcia dla TLS 1.0, i 1.1
Trzeba wymusić na dostawcy oprogramowania wsparcie dla TLS 1.2 i 1.3
 
https://www.bleepingcomputer.com/news/security/tls-10-and-tls-11-being-retired-in-2020-by-all-major-browsers/"

Proszę o jakieś info od twórców Sello w tej sprawie.

 

Edytowano przez Katarzyna Drabik

Udostępnij ten post


Link to postu

Proszę sprawdzić w Opcjach Internetowych w systemie Windows w zakładce Zaawansowane, czy jest tam włączona obsługa protokołu TLS 1.2.

Udostępnij ten post


Link to postu

W takim razie musimy zbadać sprawę. Możliwe, że biblioteka używana w Sello do obsługi maili nie korzysta z ustawień systemowych, tylko z własnych - co może być problematyczne, bo będzie wymagała aktualizacji - a to może być nie takie proste z różnych względów.

Udostępnij ten post


Link to postu
14 minut temu, Bartosz Rosa napisał:

W takim razie musimy zbadać sprawę. Możliwe, że biblioteka używana w Sello do obsługi maili nie korzysta z ustawień systemowych, tylko z własnych - co może być problematyczne, bo będzie wymagała aktualizacji - a to może być nie takie proste z różnych względów.

W tej sprawie dość długo mailuję z hostingiem. Co rusz przedstawiają jakąś propozycję rozwiązania problemu, ale na razie nic. Może rzeczywiście coś w Sello...

Udostępnij ten post


Link to postu

No jest to wina raczej tylko sello skoro wysłanie maila z tej samej skrzynki ale nie przez sello działa bez problemu. Problem występuje tylko w sello i stało się to z dnia na dzień bez żadnych modyfikacji w systemie.

Udostępnij ten post


Link to postu

A dostawca poczty nie uprzedzał o tym wyłączeniu obsługi starszych TLSów? Jeśli moje przypuszczenia się potwierdzą to z dnia na dzień niestety nie zdołamy zrealizować obsługi nowszej wersji szyfrowania, dodatkowo do podjęcia będą tutaj pewne decyzje biznesowe, związane z zakupem nowej wersji biblioteki do obsługi maili lub zmiany jej na zupełnie inną (do czego w zasadzie jesteśmy najbardziej przekonani obecnie). Problem tylko taki, że w obu przypadkach będzie konieczny z naszej strony dość duży wkład pracy, na który obecnie nie możemy sobie pozwolić bez przesuwania zaplanowanych na najbliższy czas nowości. Zmiana poczty jest na liście dużych zadań do realizacji ale nie w najbliższym czasie.

Udostępnij ten post


Link to postu
Napisano (edytowany)

Oczywiście nie jest to priorytet ale chyba dość ważny także element oprogramowania. Przez to że czegoś w sello brakuje nie można wysyłać wiadomości do klientów z szyfrowaniem co jest standardem w dzisiejszych czasach. Zmiany w TLS to nie jest zmiana z teraz tylko wcześniej to było już zapowiadane i mieliście na to czas by wdrożyć te zmiany także.  Byle w miarę szybko udało się wprowadzić te zmiany na lepsze :)

Edytowano przez Katarzyna Drabik

Udostępnij ten post


Link to postu

Ale gdzie było zapowiadane? TLS w Allegro nie ma nic wspólnego z wysyłaniem poczty. To są dwa różne światy. Zapowiadane zmiany w TLSach w Allegro są zrobione i działają.

Udostępnij ten post


Link to postu

Prosiłbym o pobranie z załączonego wątku plik Email.dll - należy go rozpakować i skopiowanie do folderu Sello. Poprzednią wersję pliku proszę przezwać lub skopiować na bok, a samo Sello zrestartować.

Prosiłbym zweryfikować czy na tym podesłanym pliku działają serwery pocztowe, które wyłączyły obsługę TLS 1.0 oraz TLS 1.1.

Proszę również zwrócić uwagę czy nie wystąpiły w związku z tą podmianą jakieś inne problemy związane z odbieraniem/wysyłaniem poczty, gdyż podmieniona w nim została wersja biblioteki użyta do obsługi serwerów pocztowych.

Plik ten można nadpisać tylko na wersję 1.33.1.

Sello 1.33.1 - Email.zip

  • Dziękuję 1

Udostępnij ten post


Link to postu
Dnia 14.02.2020 o 12:14, Bartosz Rosa napisał:

A dostawca poczty nie uprzedzał o tym wyłączeniu obsługi starszych TLSów?

Mam informację z hostingu. U mnie TLS 1.0 i 1.1 są włączone na poczcie.

Udostępnij ten post


Link to postu

×