Skocz do zawartości
Forum użytkowników
4S_ MARKET

Dublowanie aukcji z innego konta allegro

Polecane posty

Mam w bazie danych dwa konta allegro .Problem polega na tym iż aukcje  wystawione na koncie 1 pobierają się z allegro jako że pochodzą z konta numer 1 ale pobieraj się na kocie numer 2 . Konta są zautoryzowane , adresy email przypisane do kont allegro są prawidłowe . Proszę o pomoc 

Udostępnij ten post


Link to postu

Możesz zweryfikować identyfikatory au_Id dla dwóch takich aukcji, żeby sprawdzić która z nich była pierwsza? Ta poprawnie przypięta czy ta niepoprawna?

W 1.33.1 będzie prawdopodobnie dodatkowa weryfikacja czy konto posługuje się swoim tokenem a nie tokenem innego konta - na wypadek gdyby konta były niepoprawnie zautoryzowane.

Wersja 1.31 miała ten problem, że autoryzacja mogła być przeprowadzona niepoprawnie i taki stan może prowadzić do pojawiania się transakcji na innym koncie - co za tym idzie może to też dotyczyć aukcji. Sprawdź też czy nie ma dubli transakcji, bo w szczególnym przypadkach może do tego dojść. Nad rozwiązaniem pracujemy.

Udostępnij ten post


Link to postu

Zanim trafiłem na ten temat, zdążyłem tą samą sytuację opisać w innym. I tutaj wrzucę namiary

 

Przenoszę się ze sprawą tutaj i czekam na kolejną wersję Sello.

Udostępnij ten post


Link to postu
58 minut temu, Bartosz Rosa napisał:

Czyli problem z dublowaniem aukcji występuje na 1.32?

U mnie na 1.33. We wcześniejszych wersjach nie zdarzyła mi się taka sytuacja.

Udostępnij ten post


Link to postu
Napisano (edytowany)
4 godziny temu, Bartosz Rosa napisał:

Czyli problem z dublowaniem aukcji występuje na 1.32?

Ja też dalej na 1.32 i też zdarzyły mi się duble aukcji. Ostatnio dużo robiłem różnych zmian na aukcjach i pobierałem różne dane dla różnych kont i też pojawiła się dość spora ilość zdublowanych aukcji, które nie miały miniaturki, cennika itp i w ogóle nie dotyczyły tego konta, na którym faktycznie były wystawione. Wyfiltrowałem po tych, które nie mają miniaturki (bo mam taki filtr w aukcjach trwających) i je najzwyczajniej usunąłem.

W ogóle w Sello jest jakiś problem z wieloma kontami. Nie ma dnia, żebym nie dostał informacji typu "Forbidden" albo "niepoprawna ilość sztuk na aukcji" albo "zdjęcia w ofercie są niepoprawne" podczas wykonywania jakiejś zmiany na aukcjach. Autoryzacja niby pomaga ale szybciej sobie z tym radze odpalając wysyłkę zmian z Sello na innym kompie gdzie przechodzi bez problemu.

Edytowano przez maniootek •

Udostępnij ten post


Link to postu
10 godzin temu, Bartosz Rosa napisał:

Czyli problem z dublowaniem aukcji występuje na 1.32?

Tak Bartku , na 1.32 dziś zrobiłem 1.33 z autoryzowałem konta i nadal zabiera wszystkie aukcje z konta B i pokazuje je na a 

Udostępnij ten post


Link to postu

Witam.

Problem jest nam znany, występował także w naszych aplikacjach przy autoryzacji.
Potrafi się dziać tak, że cache (ciasteczka) przeglądarki pamiętają dane wcześniej autoryzowanego konta i takie przypisują pod kolejne.

Sprawdzone obejście problemu - to usuwanie historii przeglądania pod IE (z tej przeglądarki korzystają kontrolki wbudowane w aplikacje) przed każdą autoryzacją.

Czyli:

- Wchodzimy do IE, czyścimy cache ( ctrl+shift+delete , usuń)

- Odpalamy Sello. Autoryzujemy konto X. Zamykamy Sello.

Powyższe kroki powtarzamy dla każdego następnego konta.

 

pozdrawiam

Dawid Kopański

bettersoft.pl

 

  • Lubię to 1
  • Dziękuję 1

Udostępnij ten post


Link to postu
1 minutę temu, Dawid Kopański napisał:

Witam.

Problem jest nam znany, występował także w naszych aplikacjach przy autoryzacji.
Potrafi się dziać tak, że cache (ciasteczka) przeglądarki pamiętają dane wcześniej autoryzowanego konta i takie przypisują pod kolejne.

Sprawdzone obejście problemu - to usuwanie historii przeglądania pod IE (z tej przeglądarki korzystają kontrolki wbudowane w aplikacje) przed każdą autoryzacją.

Czyli:

- Wchodzimy do IE, czyścimy cache ( ctrl+shift+delete , usuń)

- Odpalamy Sello. Autoryzujemy konto X. Zamykamy Sello.

Powyższe kroki powtarzamy dla każdego następnego konta.

 

pozdrawiam

Dawid Kopański

bettersoft.pl

 

Problem rozwiązany , potwierdzam pomogło 

Udostępnij ten post


Link to postu

Od wersji 1.32 jest dodana weryfikacja przy autoryzowaniu konta, która sprawdza czy token zwrócony do kolejnego konta jest faktycznie dla tego konta. Cache nie powinien tutaj nic wnosić, bo te tokeny zwracane są różne i poprawne dla każdego konta.

Autoryzacja w 1.31 faktycznie mogła wymagać czyszczenia cache, ale od 1.32 nie powinno to być wymagane.

 

Chociaż z drugiej strony, wczoraj na testowym serwisie Allegro pokazało nam się zamówienie konta X na koncie Y (przynajmniej taka była informacja kto jest zalogowany obecnie).

Udostępnij ten post


Link to postu

@Dawid Kopański czy po takiej pełnej autoryzacji zdarza się, że autoryzacja wysiada po jakimś czasie i proces trzeba powtarzać?

@4S_ MARKET daj znać jeśli zajdzie konieczność ponownej autoryzacji.

Oczywiście jeśli w Sello są już aukcje podpięte do niepoprawnego konta to próba ich aktualizacji będzie generować zapewne 403 Forbidden.

 

Udostępnij ten post


Link to postu
11 minut temu, Bartosz Rosa napisał:

@Dawid Kopański czy po takiej pełnej autoryzacji zdarza się, że autoryzacja wysiada po jakimś czasie i proces trzeba powtarzać?

@4S_ MARKET daj znać jeśli zajdzie konieczność ponownej autoryzacji.

Oczywiście jeśli w Sello są już aukcje podpięte do niepoprawnego konta to próba ich aktualizacji będzie generować zapewne 403 Forbidden.

 

Tych aukcji nie podpinałem , na ten moment po pobraniu pełnych danych aukcje się już nie dublują . 

 

Jeśli chodzi o autoryzacje o której piszę @Dawid Kopański niestety ale czasami zdarza się taki problem ponownie 

Udostępnij ten post


Link to postu

Pytanie, czy autoryzacja na nowej wersji wystarczy aby duble się nie pojawiały czy trzeba faktycznie czyścić ten cache.

Udostępnij ten post


Link to postu

Wygląda na to że należy zautoryzować   ponownie konta czyszcząc cash za każdym razem  po każdej autryzacji jak napisał @Dawid Kopański. Dziwne jest to że problem wystąpił na wersji 1.32 . Ponieważ nigdy wcześniej się tak nie działo. 

Udostępnij ten post


Link to postu

Ja dzisiaj dostałem błąd typu FORBIDDEN dwa razy w przeciągu 30-minut w przypadku aktualizacji aukcji trwającej (opis + zdjęcia) na różnych kontach. Pierwszy raz poradziłem sobie z nim, tak jak to opisałem wcześniej czyli BEZ PONOWNEJ AUTORYZACJI tylko wysłałem zmiany do serwisu z innego komputera i przeszło bez problemu. Drugim razem próbowałem usunąć cache tak jak to @Dawid Kopański opisał w poście powyżej ale najpierw eksperymentalnie bez wyłączania Sello i nic to nie dało, więc postąpiłem tak jak to dokładnie zostało opisane czyli wyłączyłem Sello, usunąłem cache, włączyłem Sello, puściłem zmiany i przeszły bez problemu.

Może warto się temu przyjrzeć dokładnie? Błędy z autoryzacją są bardzo irytujące w Sello.

Udostępnij ten post


Link to postu

Zdajemy sobie sprawę i szukamy przyczyn tego problemu od kilku dni.

22 godziny temu, maniootek • napisał:

tylko wysłałem zmiany do serwisu z innego komputera i przeszło bez problemu

A sam tylko restart Sello na stanowisku na którym pojawia się Forbidden coś daje?

Udostępnij ten post


Link to postu
1 godzinę temu, Bartosz Rosa napisał:

A sam tylko restart Sello na stanowisku na którym pojawia się Forbidden coś daje?

Sam restart Sello nic nie daje ale restart z czyszczeniem cache już tak.

Udostępnij ten post


Link to postu

To jest podwójnie dziwne, bo konektor REST Allegro nie korzysta z cache'u przeglądarki - jedynie autoryzacja z niej korzysta, bo wyświetla stronę logowania w komponencie HTML.

Mógłbyś przy następnej takiej sytuacji włączyć logowanie, doprowadzić do błędu forbidden a następnie zresetować cache i ponowić wykonanie nieudanej poprzednio operacji?

Udostępnij ten post


Link to postu
Dnia 29.01.2020 o 16:04, Bartosz Rosa napisał:

Mógłbyś przy następnej takiej sytuacji włączyć logowanie, doprowadzić do błędu forbidden a następnie zresetować cache i ponowić wykonanie nieudanej poprzednio operacji?

ok włączyłem to pracownikowi, który dzisiaj będzie aktualizował aukcje

gdzie potem znajde ten plik z logiem?

Udostępnij ten post


Link to postu
4 godziny temu, MARCIN e-kupowanie.pl napisał:

U mnie jest tutaj:

image.png.90d5e281eb2ec63c2726b67314f69584.png

U mnie nie ma takiego katalogu :/
(program serwisowy włączyłem z uprawnieniami admina)

gdzie to sprawdzić w rejestrze?

Udostępnij ten post


Link to postu

×